25 September 2014

Ayo Mutakhirkan Bash ke Versi 4.2x!!!

Saya belum mengetahui efek yang lebih besar ketika mengetikan perintah, env x='() { :;}; echo vulnerable' bash -c "echo this is a test" pada Terminal. Ketika dicoba pada mesin virtual dengan sistem operasi yang lebih tua dari sistem operasi yang saya gunakan setiap hari tenyata muncul pesan:
vulnerable
this is a test
Berhubung mesin yang saya gunakan setiap hari selalu dimutakhirkan jadi saat menjalankan perintah diatas maka munculnya berbeda, seperti:
bash: warning: x: ignoring function definition attempt
bash: error importing function definition for `x'
this is a test
Daripada pening dan bingung, SEGERA mutakhirkan versi Bash Anda ke versi 4.2x atau yg lebih tinggi.

No comments:

Post a Comment

Disqus for Dedy selalu Milisdad